Back to overview
Degraded

Sandbox Service - Elevated Latency and Errors

May 26, 2026 at 5:45pm UTC
Affected services
Sandboxes

Resolved
May 26, 2026 at 11:34pm UTC

The elevated latency and intermittent errors affecting the Sandbox APIs have been fully resolved. The root cause was a routing change in a recently deployed sandbox backend service, which caused scheduled background jobs to retry beyond intended bounds and place pressure on shared resources.

Updated
May 26, 2026 at 9:55pm UTC

The fix has been deployed to production and Sandbox APIs are operating normally. Latency and error rates are back within expected ranges. We're monitoring closely before marking this resolved.

Updated
May 26, 2026 at 8:19pm UTC

The team has a fix for the service issue which is currently being tested on the Prime staging environments.

Created
May 26, 2026 at 5:45pm UTC

We are currently investigating elevated latency and intermittent errors affecting the Sandbox provisioning and CRUD APIs.